Missing Authorization Affecting ruby2.5-rubygem-kramdown package, versions <1.15.0-150000.3.3.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
4.56% (91st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES154-RUBY25RUBYGEMKRAMDOWN-3021677
  • published13 Sept 2022
  • disclosed12 Sept 2022

Introduced: 12 Sep 2022

CVE-2020-14001  (opens in a new tab)
CWE-862  (opens in a new tab)

How to fix?

Upgrade SLES:15.4 ruby2.5-rubygem-kramdown to version 1.15.0-150000.3.3.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ruby2.5-rubygem-kramdown package and not the ruby2.5-rubygem-kramdown package as distributed by SLES. See How to fix? for SLES:15.4 relevant fixed versions and status.

The kramdown gem before 2.3.0 for Ruby processes the template option inside Kramdown documents by default, which allows unintended read access (such as template="/etc/passwd") or unintended embedded Ruby code execution (such as a string that begins with template="string://<%= `). NOTE: kramdown is used in Jekyll, GitLab Pages, GitHub Pages, and Thredded Forum.

CVSS Base Scores

version 3.1