Improper Input Validation Affecting ruby2.5-rubygem-rack package, versions <2.0.8-150000.3.9.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
2.94% (86th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES154-RUBY25RUBYGEMRACK-3032228
  • published24 Sept 2022
  • disclosed23 Sept 2022

Introduced: 23 Sep 2022

CVE-2020-8184  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade SLES:15.4 ruby2.5-rubygem-rack to version 2.0.8-150000.3.9.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ruby2.5-rubygem-rack package and not the ruby2.5-rubygem-rack package as distributed by SLES. See How to fix? for SLES:15.4 relevant fixed versions and status.

A reliance on cookies without validation/integrity check security vulnerability exists in rack < 2.2.3, rack < 2.1.4 that makes it is possible for an attacker to forge a secure or host-only cookie prefix.

CVSS Base Scores

version 3.1