Cross-site Scripting (XSS) Affecting ruby2.5-rubygem-rails-html-sanitizer package, versions <1.0.4-150000.4.6.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
1.19% (68th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES154-RUBY25RUBYGEMRAILSHTMLSANITIZER-5912590
  • published21 Sept 2023
  • disclosed20 Sept 2023

Introduced: 20 Sep 2023

CVE-2022-23520  (opens in a new tab)
CWE-79  (opens in a new tab)

How to fix?

Upgrade SLES:15.4 ruby2.5-rubygem-rails-html-sanitizer to version 1.0.4-150000.4.6.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ruby2.5-rubygem-rails-html-sanitizer package and not the ruby2.5-rubygem-rails-html-sanitizer package as distributed by SLES. See How to fix? for SLES:15.4 relevant fixed versions and status.

rails-html-sanitizer is responsible for sanitizing HTML fragments in Rails applications. Prior to version 1.4.4, there is a possible XSS vulnerability with certain configurations of Rails::Html::Sanitizer due to an incomplete fix of CVE-2022-32209. Rails::Html::Sanitizer may allow an attacker to inject content if the application developer has overridden the sanitizer's allowed tags to allow both "select" and "style" elements. Code is only impacted if allowed tags are being overridden. This issue is patched in version 1.4.4. All users overriding the allowed tags to include both "select" and "style" should either upgrade or use this workaround: Remove either "select" or "style" from the overridden allowed tags. NOTE: Code is not impacted if allowed tags are overridden using either the :tags option to the Action View helper method sanitize or the :tags option to the instance method SafeListSanitizer#sanitize.

CVSS Base Scores

version 3.1