CVE-2023-1521 Affecting sccache package, versions <0.4.2~3-150400.3.3.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.36% (28th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES154-SCCACHE-5882668
  • published6 Sept 2023
  • disclosed5 Sept 2023

Introduced: 5 Sep 2023

CVE-2023-1521  (opens in a new tab)

How to fix?

Upgrade SLES:15.4 sccache to version 0.4.2~3-150400.3.3.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream sccache package and not the sccache package as distributed by SLES. See How to fix? for SLES:15.4 relevant fixed versions and status.

On Linux the sccache client can execute arbitrary code with the privileges of a local sccache server, by preloading the code in a shared library passed to LD_PRELOAD.

If the server is run as root (which is the default when installing the snap package https://snapcraft.io/sccache ), this means a user running the sccache client can get root privileges.

CVSS Base Scores

version 3.1