Race Condition Affecting slurm_22_05-sql package, versions <22.05.10-150300.7.6.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.19% (9th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES154-SLURM2205SQL-6091309
  • published28 Nov 2023
  • disclosed27 Nov 2023

Introduced: 27 Nov 2023

CVE-2023-41914  (opens in a new tab)
CWE-362  (opens in a new tab)

How to fix?

Upgrade SLES:15.4 slurm_22_05-sql to version 22.05.10-150300.7.6.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream slurm_22_05-sql package and not the slurm_22_05-sql package as distributed by SLES. See How to fix? for SLES:15.4 relevant fixed versions and status.

SchedMD Slurm 23.02.x before 23.02.6 and 22.05.x before 22.05.10 allows filesystem race conditions for gaining ownership of a file, overwriting a file, or deleting files.

CVSS Base Scores

version 3.1