Improper Restriction of Recursive Entity References in DTDs ('XML Entity Expansion') Affecting snakeyaml package, versions <1.31-150200.3.8.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
2.93% (88th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES154-SNAKEYAML-3036020
  • published29 Sept 2022
  • disclosed26 Sept 2022

Introduced: 26 Sep 2022

CVE-2022-25857  (opens in a new tab)
CWE-776  (opens in a new tab)

How to fix?

Upgrade SLES:15.4 snakeyaml to version 1.31-150200.3.8.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream snakeyaml package and not the snakeyaml package as distributed by SLES. See How to fix? for SLES:15.4 relevant fixed versions and status.

The package org.yaml:snakeyaml from 0 and before 1.31 are vulnerable to Denial of Service (DoS) due missing to nested depth limitation for collections.

CVSS Base Scores

version 3.1