Integer Overflow or Wraparound Affecting spice-vdagent package, versions <0.21.0-150300.3.6.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.11% (2nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES154-SPICEVDAGENT-18518217
  • published4 Aug 2026
  • disclosed3 Aug 2026

Introduced: 3 Aug 2026

CVE-2026-57965  (opens in a new tab)
CWE-190  (opens in a new tab)

How to fix?

Upgrade SLES:15.4 spice-vdagent to version 0.21.0-150300.3.6.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream spice-vdagent package and not the spice-vdagent package as distributed by SLES. See How to fix? for SLES:15.4 relevant fixed versions and status.

A flaw was found in spice-vdagent. A malicious or compromised SPICE host can trigger an integer overflow by sending a specially crafted message. This vulnerability can lead to a heap buffer overflow, causing the spice-vdagent daemon to crash and resulting in a Denial of Service (DoS) for the virtual machine. This issue requires the SPICE host to be untrusted or compromised for exploitation.

CVSS Base Scores

version 3.1