Use After Free Affecting squid package, versions <5.7-150400.3.41.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
4.78% (91st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES154-SQUID-21751112
  • published27 Oct 2026
  • disclosed26 Oct 2026

Introduced: 26 Oct 2026

NewCVE-2023-49288  (opens in a new tab)
CWE-416  (opens in a new tab)

How to fix?

Upgrade SLES:15.4 squid to version 5.7-150400.3.41.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream squid package and not the squid package as distributed by SLES. See How to fix? for SLES:15.4 relevant fixed versions and status.

Squid is a caching proxy for the Web supporting HTTP, HTTPS, FTP, and more. Affected versions of squid are subject to a a Use-After-Free bug which can lead to a Denial of Service attack via collapsed forwarding. All versions of Squid from 3.5 up to and including 5.9 configured with "collapsed_forwarding on" are vulnerable. Configurations with "collapsed_forwarding off" or without a "collapsed_forwarding" directive are not vulnerable. This bug is fixed by Squid version 6.0.1. Users are advised to upgrade. Users unable to upgrade should remove all collapsed_forwarding lines from their squid.conf.

CVSS Base Scores

version 3.1