Incorrect Authorization Affecting strongswan-hmac package, versions <5.9.11-150400.19.40.2


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.45% (39th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES154-STRONGSWANHMAC-19856082
  • published16 Sept 2026
  • disclosed14 Sept 2026

Introduced: 14 Sep 2026

CVE-2026-78134  (opens in a new tab)
CWE-863  (opens in a new tab)

How to fix?

Upgrade SLES:15.4 strongswan-hmac to version 5.9.11-150400.19.40.2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream strongswan-hmac package and not the strongswan-hmac package as distributed by SLES. See How to fix? for SLES:15.4 relevant fixed versions and status.

strongSwan 4.5.0 through 6.0.7 has Incorrect Access Control in the eap-ttls and eap-peap plugins because there can be a missing or mismatched inner EAP identity.

CVSS Base Scores

version 3.1