Double Free Affecting strongswan-ipsec package, versions <5.9.11-150400.19.35.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.42% (34th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES154-STRONGSWANIPSEC-17319948
  • published12 Jun 2026
  • disclosed11 Jun 2026

Introduced: 11 Jun 2026

CVE-2026-47895  (opens in a new tab)
CWE-415  (opens in a new tab)

How to fix?

Upgrade SLES:15.4 strongswan-ipsec to version 5.9.11-150400.19.35.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream strongswan-ipsec package and not the strongswan-ipsec package as distributed by SLES. See How to fix? for SLES:15.4 relevant fixed versions and status.

In strongSwan before 6.0.7, identity parsing/cloning is mishandled. Parsed EAP-Identities that result in an empty but non-NULL encoding are not correctly cloned and trigger a double-free once the duplicates are destroyed.

CVSS Base Scores

version 3.1