Integer Overflow or Wraparound Affecting suse-module-tools package, versions <15.4.18-150400.3.14.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.31% (24th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES154-SUSEMODULETOOLS-6016517
  • published20 Oct 2023
  • disclosed19 Oct 2023

Introduced: 19 Oct 2023

CVE-2023-23559  (opens in a new tab)
CWE-190  (opens in a new tab)

How to fix?

Upgrade SLES:15.4 suse-module-tools to version 15.4.18-150400.3.14.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream suse-module-tools package and not the suse-module-tools package as distributed by SLES. See How to fix? for SLES:15.4 relevant fixed versions and status.

In rndis_query_oid in drivers/net/wireless/rndis_wlan.c in the Linux kernel through 6.1.5, there is an integer overflow in an addition.

CVSS Base Scores

version 3.1