Directory Traversal Affecting typelib-1_0-Rsvg-2_0 package, versions <2.52.10-150400.3.6.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
2.33% (83rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES154-TYPELIB10RSVG20-5808753
  • published29 Jul 2023
  • disclosed28 Jul 2023

Introduced: 28 Jul 2023

CVE-2023-38633  (opens in a new tab)
CWE-22  (opens in a new tab)

How to fix?

Upgrade SLES:15.4 typelib-1_0-Rsvg-2_0 to version 2.52.10-150400.3.6.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream typelib-1_0-Rsvg-2_0 package and not the typelib-1_0-Rsvg-2_0 package as distributed by SLES. See How to fix? for SLES:15.4 relevant fixed versions and status.

A directory traversal problem in the URL decoder of librsvg before 2.56.3 could be used by local or remote attackers to disclose files (on the local filesystem outside of the expected area), as demonstrated by href=".?../../../../../../../../../../etc/passwd" in an xi:include element.

CVSS Base Scores

version 3.1