Out-of-bounds Write Affecting apache-commons-configuration package, versions <1.10-150200.3.11.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
1.73% (75th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES155-APACHECOMMONSCONFIGURATION-6672026
  • published23 Apr 2024
  • disclosed22 Apr 2024

Introduced: 22 Apr 2024

CVE-2024-29133  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade SLES:15.5 apache-commons-configuration to version 1.10-150200.3.11.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream apache-commons-configuration package and not the apache-commons-configuration package as distributed by SLES. See How to fix? for SLES:15.5 relevant fixed versions and status.

Out-of-bounds Write vulnerability in Apache Commons Configuration.This issue affects Apache Commons Configuration: from 2.0 before 2.10.1.

Users are recommended to upgrade to version 2.10.1, which fixes the issue.

CVSS Base Scores

version 3.1