Reachable Assertion Affecting avahi-utils-gtk package, versions <0.8-150400.7.16.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.32% (25th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES155-AVAHIUTILSGTK-6508683
  • published28 Mar 2024
  • disclosed27 Mar 2024

Introduced: 27 Mar 2024

CVE-2023-38469  (opens in a new tab)
CWE-617  (opens in a new tab)

How to fix?

Upgrade SLES:15.5 avahi-utils-gtk to version 0.8-150400.7.16.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream avahi-utils-gtk package and not the avahi-utils-gtk package as distributed by SLES. See How to fix? for SLES:15.5 relevant fixed versions and status.

A vulnerability was found in Avahi, where a reachable assertion exists in avahi_dns_packet_append_record.

CVSS Base Scores

version 3.1