Directory Traversal Affecting gradle package, versions <4.4.1-150200.3.24.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.28% (19th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES155-GRADLE-7923901
  • published7 Sept 2024
  • disclosed6 Sept 2024

Introduced: 6 Sep 2024

CVE-2023-35946  (opens in a new tab)
CWE-22  (opens in a new tab)

How to fix?

Upgrade SLES:15.5 gradle to version 4.4.1-150200.3.24.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream gradle package and not the gradle package as distributed by SLES. See How to fix? for SLES:15.5 relevant fixed versions and status.

Gradle is a build tool with a focus on build automation and support for multi-language development. When Gradle writes a dependency into its dependency cache, it uses the dependency's coordinates to compute a file location. With specially crafted dependency coordinates, Gradle can be made to write files into an unintended location. The file may be written outside the dependency cache or over another file in the dependency cache. This vulnerability could be used to poison the dependency cache or overwrite important files elsewhere on the filesystem where the Gradle process has write permissions. Exploiting this vulnerability requires an attacker to have control over a dependency repository used by the Gradle build or have the ability to modify the build's configuration. It is unlikely that this would go unnoticed. A fix has been released in Gradle 7.6.2 and 8.2 to protect against this vulnerability. Gradle will refuse to cache dependencies that have path traversal elements in their dependency coordinates. It is recommended that users upgrade to a patched version. If you are unable to upgrade to Gradle 7.6.2 or 8.2, dependency verification will make this vulnerability more difficult to exploit.

CVSS Base Scores

version 3.1