Out-of-bounds Write Affecting hdf5_1_10_11-gnu-mvapich2-hpc package, versions <1.10.11-150400.3.12.1



    Attack Complexity Low
    User Interaction Required
    Availability High

    Threat Intelligence

    EPSS 0.09% (36th percentile)
Expand this section
7.5 high
Expand this section
6.6 medium
Expand this section
Red Hat
7.5 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-SLES155-HDF511011GNUMVAPICH2HPC-6256266
  • published 21 Feb 2024
  • disclosed 20 Feb 2024

How to fix?

Upgrade SLES:15.5 hdf5_1_10_11-gnu-mvapich2-hpc to version 1.10.11-150400.3.12.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream hdf5_1_10_11-gnu-mvapich2-hpc package and not the hdf5_1_10_11-gnu-mvapich2-hpc package as distributed by SLES. See How to fix? for SLES:15.5 relevant fixed versions and status.

Buffer Overflow vulnerability in HDFGroup hdf5-h5dump 1.12.0 through 1.13.0 allows attackers to cause a denial of service via h5tools_str_sprint in /hdf5/tools/lib/h5tools_str.c.