Integer Overflow or Wraparound Affecting ImageMagick-devel package, versions <7.1.0.9-150400.6.21.1


Severity

Recommended
medium

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.96% (60th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES155-IMAGEMAGICKDEVEL-5664789
  • published2 Jun 2023
  • disclosed1 Jun 2023

Introduced: 1 Jun 2023

CVE-2023-34151  (opens in a new tab)
CWE-190  (opens in a new tab)

How to fix?

Upgrade SLES:15.5 ImageMagick-devel to version 7.1.0.9-150400.6.21.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ImageMagick-devel package and not the ImageMagick-devel package as distributed by SLES. See How to fix? for SLES:15.5 relevant fixed versions and status.

A vulnerability was found in ImageMagick. This security flaw ouccers as an undefined behaviors of casting double to size_t in svg, mvg and other coders (recurring bugs of CVE-2022-32546).

CVSS Base Scores

version 3.1