Out-of-bounds Write Affecting indent package, versions <2.2.11-150000.3.6.1


Severity

Recommended
medium

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.44% (37th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES155-INDENT-5875812
  • published30 Aug 2023
  • disclosed24 Aug 2023

Introduced: 24 Aug 2023

CVE-2023-40305  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade SLES:15.5 indent to version 2.2.11-150000.3.6.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream indent package and not the indent package as distributed by SLES. See How to fix? for SLES:15.5 relevant fixed versions and status.

GNU indent 2.2.13 has a heap-based buffer overflow in search_brace in indent.c via a crafted file.

CVSS Base Scores

version 3.1