Out-of-bounds Write Affecting indent package, versions <2.2.11-150000.3.9.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.31% (23rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES155-INDENT-6481755
  • published23 Mar 2024
  • disclosed21 Mar 2024

Introduced: 21 Mar 2024

CVE-2024-0911  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade SLES:15.5 indent to version 2.2.11-150000.3.9.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream indent package and not the indent package as distributed by SLES. See How to fix? for SLES:15.5 relevant fixed versions and status.

A flaw was found in indent, a program for formatting C code. This issue may allow an attacker to trick a user into processing a specially crafted file to trigger a heap-based buffer overflow, causing the application to crash.

CVSS Base Scores

version 3.1