Integer Overflow or Wraparound Affecting kernel-firmware-nvidia-gspx-G06 package, versions <550.54.14-150500.11.18.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.26% (17th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES155-KERNELFIRMWARENVIDIAGSPXG06-6394455
  • published6 Mar 2024
  • disclosed5 Mar 2024

Introduced: 5 Mar 2024

CVE-2022-42265  (opens in a new tab)
CWE-190  (opens in a new tab)

How to fix?

Upgrade SLES:15.5 kernel-firmware-nvidia-gspx-G06 to version 550.54.14-150500.11.18.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream kernel-firmware-nvidia-gspx-G06 package and not the kernel-firmware-nvidia-gspx-G06 package as distributed by SLES. See How to fix? for SLES:15.5 relevant fixed versions and status.

NVIDIA GPU Display Driver for Linux contains a vulnerability in the kernel mode layer (nvidia.ko), where an integer overflow may lead to information disclosure or data tampering.

CVSS Base Scores

version 3.1