Integer Overflow or Wraparound Affecting libcap2 package, versions <2.63-150400.3.3.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.58% (46th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES155-LIBCAP2-5752426
  • published4 Jul 2023
  • disclosed3 Jul 2023

Introduced: 3 Jul 2023

CVE-2023-2603  (opens in a new tab)
CWE-190  (opens in a new tab)

How to fix?

Upgrade SLES:15.5 libcap2 to version 2.63-150400.3.3.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libcap2 package and not the libcap2 package as distributed by SLES. See How to fix? for SLES:15.5 relevant fixed versions and status.

A vulnerability was found in libcap. This issue occurs in the _libcap_strdup() function and can lead to an integer overflow if the input string is close to 4GiB.

CVSS Base Scores

version 3.1