CVE-2024-28285 Affecting libcryptopp-devel package, versions <8.6.0-150400.3.9.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.51% (39th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES155-LIBCRYPTOPPDEVEL-10303501
  • published5 Jun 2025
  • disclosed4 Jun 2025

Introduced: 4 Jun 2025

CVE-2024-28285  (opens in a new tab)

How to fix?

Upgrade SLES:15.5 libcryptopp-devel to version 8.6.0-150400.3.9.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libcryptopp-devel package and not the libcryptopp-devel package as distributed by SLES. See How to fix? for SLES:15.5 relevant fixed versions and status.

A Fault Injection vulnerability in the SymmetricDecrypt function in cryptopp/elgamal.h of Cryptopp Crypto++ 8.9, allows an attacker to co-reside in the same system with a victim process to disclose information and escalate privileges.

CVSS Base Scores

version 3.1