Buffer Overflow Affecting libeconf0 package, versions <0.5.2-150400.3.6.1


Severity

Recommended
high

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.57% (43rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES155-LIBECONF0-5929222
  • published4 Oct 2023
  • disclosed3 Oct 2023

Introduced: 3 Oct 2023

CVE-2023-32181  (opens in a new tab)
CWE-120  (opens in a new tab)

How to fix?

Upgrade SLES:15.5 libeconf0 to version 0.5.2-150400.3.6.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libeconf0 package and not the libeconf0 package as distributed by SLES. See How to fix? for SLES:15.5 relevant fixed versions and status.

A Buffer Copy without Checking Size of Input ('Classic Buffer Overflow') vulnerability in openSUSE libeconf allows for DoS via malformed configuration files This issue affects libeconf: before 0.5.2.

CVSS Base Scores

version 3.1