Integer Overflow or Wraparound Affecting libgsf-lang package, versions <1.14.50-150400.3.6.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.46% (37th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES155-LIBGSFLANG-8349786
  • published7 Nov 2024
  • disclosed6 Nov 2024

Introduced: 6 Nov 2024

CVE-2024-42415  (opens in a new tab)
CWE-190  (opens in a new tab)

How to fix?

Upgrade SLES:15.5 libgsf-lang to version 1.14.50-150400.3.6.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libgsf-lang package and not the libgsf-lang package as distributed by SLES. See How to fix? for SLES:15.5 relevant fixed versions and status.

An integer overflow vulnerability exists in the Compound Document Binary File format parser of v1.14.52 of the GNOME Project G Structured File Library (libgsf). A specially crafted file can result in an integer overflow that allows for a heap-based buffer overflow when processing the sector allocation table. This can lead to arbitrary code execution. An attacker can provide a malicious file to trigger this vulnerability.

CVSS Base Scores

version 3.1