Out-of-Bounds Affecting libhdf5_1_10_11-gnu-openmpi4-hpc package, versions <1.10.11-150400.3.12.1


0.0
low
0
10

Snyk CVSS

    Attack Complexity Low
    User Interaction Required

    Threat Intelligence

    EPSS 0.09% (40th percentile)
Expand this section
NVD
6.5 medium
Expand this section
Red Hat
5.5 medium
Expand this section
SUSE
3.3 low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-SLES155-LIBHDF511011GNUOPENMPI4HPC-6256002
  • published 21 Feb 2024
  • disclosed 20 Feb 2024

How to fix?

Upgrade SLES:15.5 libhdf5_1_10_11-gnu-openmpi4-hpc to version 1.10.11-150400.3.12.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libhdf5_1_10_11-gnu-openmpi4-hpc package and not the libhdf5_1_10_11-gnu-openmpi4-hpc package as distributed by SLES. See How to fix? for SLES:15.5 relevant fixed versions and status.

A buffer overflow in H5O__layout_encode in H5Olayout.c in the HDF HDF5 through 1.10.4 library allows attackers to cause a denial of service via a crafted HDF5 file. This issue was triggered while repacking an HDF5 file, aka "Invalid write of size 2."