Reachable Assertion Affecting libjq1 package, versions <1.7.1-150000.3.25.1


Severity

Recommended
0.0
low
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.22% (13th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES155-LIBJQ1-20044018
  • published22 Sept 2026
  • disclosed21 Sept 2026

Introduced: 21 Sep 2026

CVE-2025-9403  (opens in a new tab)
CWE-617  (opens in a new tab)

How to fix?

Upgrade SLES:15.5 libjq1 to version 1.7.1-150000.3.25.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libjq1 package and not the libjq1 package as distributed by SLES. See How to fix? for SLES:15.5 relevant fixed versions and status.

A vulnerability was determined in jqlang jq up to 1.6. Impacted is the function run_jq_tests of the file jq_test.c of the component JSON Parser. Executing manipulation can lead to reachable assertion. The attack requires local access. The exploit has been publicly disclosed and may be utilized. Other versions might be affected as well.

CVSS Base Scores

version 3.1