Out-of-bounds Write Affecting libjq-devel package, versions <1.7.1-150000.3.25.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.51% (41st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES155-LIBJQDEVEL-20043987
  • published22 Sept 2026
  • disclosed21 Sept 2026

Introduced: 21 Sep 2026

CVE-2023-50246  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade SLES:15.5 libjq-devel to version 1.7.1-150000.3.25.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libjq-devel package and not the libjq-devel package as distributed by SLES. See How to fix? for SLES:15.5 relevant fixed versions and status.

jq is a command-line JSON processor. Version 1.7 is vulnerable to heap-based buffer overflow. Version 1.7.1 contains a patch for this issue.

CVSS Base Scores

version 3.1