Cross-site Request Forgery (CSRF) Affecting libluajit-5_1-2 package, versions <2.1.0~beta3+git.1624618403.e9577376-150400.4.2.1


Severity

Recommended
medium

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.84% (57th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES155-LIBLUAJIT512-6369031
  • published3 Mar 2024
  • disclosed6 Dec 2023

Introduced: 6 Dec 2023

CVE-2017-7557  (opens in a new tab)
CWE-352  (opens in a new tab)

How to fix?

Upgrade SLES:15.5 libluajit-5_1-2 to version 2.1.0~beta3+git.1624618403.e9577376-150400.4.2.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libluajit-5_1-2 package and not the libluajit-5_1-2 package as distributed by SLES. See How to fix? for SLES:15.5 relevant fixed versions and status.

dnsdist version 1.1.0 is vulnerable to a flaw in authentication mechanism for REST API potentially allowing CSRF attack.