Out-of-bounds Write Affecting libMagick++-devel package, versions <7.1.0.9-150400.6.24.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.37% (29th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES155-LIBMAGICKDEVEL-5789901
  • published20 Jul 2023
  • disclosed19 Jul 2023

Introduced: 19 Jul 2023

CVE-2023-34474  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade SLES:15.5 libMagick++-devel to version 7.1.0.9-150400.6.24.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libMagick++-devel package and not the libMagick++-devel package as distributed by SLES. See How to fix? for SLES:15.5 relevant fixed versions and status.

A heap-based buffer overflow issue was discovered in ImageMagick's ReadTIM2ImageData() function in coders/tim2.c. A local attacker could trick the user in opening specially crafted file, triggering an out-of-bounds read error, allowing an application to crash, resulting in a denial of service.

CVSS Base Scores

version 3.1