Directory Traversal Affecting libpcp_mmv1 package, versions <6.2.0-150500.8.9.1


Severity

Recommended
critical

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.51% (43rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES155-LIBPCPMMV1-18564660
  • published6 Aug 2026
  • disclosed5 Aug 2026

Introduced: 5 Aug 2026

CVE-2026-16531  (opens in a new tab)
CWE-22  (opens in a new tab)

How to fix?

Upgrade SLES:15.5 libpcp_mmv1 to version 6.2.0-150500.8.9.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libpcp_mmv1 package and not the libpcp_mmv1 package as distributed by SLES. See How to fix? for SLES:15.5 relevant fixed versions and status.

An unauthenticated remote attacker can exploit a path traversal vulnerability in the PCP pmproxy logger servlet using a crafted hostname. This allows arbitrary file and directory creation, potentially leading to a denial of service.

CVSS Base Scores

version 3.1