Buffer Overflow Affecting libpskc0 package, versions <2.6.2-150000.3.5.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
4.74% (92nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES155-LIBPSKC0-6227193
  • published3 Feb 2024
  • disclosed2 Feb 2024

Introduced: 2 Feb 2024

CVE-2020-12823  (opens in a new tab)
CWE-120  (opens in a new tab)

How to fix?

Upgrade SLES:15.5 libpskc0 to version 2.6.2-150000.3.5.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libpskc0 package and not the libpskc0 package as distributed by SLES. See How to fix? for SLES:15.5 relevant fixed versions and status.

OpenConnect 8.09 has a buffer overflow, causing a denial of service (application crash) or possibly unspecified other impact, via crafted certificate data to get_cert_name in gnutls.c.

CVSS Base Scores

version 3.1