Out-of-bounds Read Affecting libX11-devel package, versions <1.6.5-150000.3.33.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.67% (51st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES155-LIBX11DEVEL-5932661
  • published5 Oct 2023
  • disclosed4 Oct 2023

Introduced: 4 Oct 2023

CVE-2023-43785  (opens in a new tab)
CWE-125  (opens in a new tab)

How to fix?

Upgrade SLES:15.5 libX11-devel to version 1.6.5-150000.3.33.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libX11-devel package and not the libX11-devel package as distributed by SLES. See How to fix? for SLES:15.5 relevant fixed versions and status.

A vulnerability was found in libX11 due to a boundary condition within the _XkbReadKeySyms() function. This flaw allows a local user to trigger an out-of-bounds read error and read the contents of memory on the system.

CVSS Base Scores

version 3.1