Expired Pointer Dereference Affecting libxslt-tools package, versions <1.1.34-150400.3.13.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.17% (7th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES155-LIBXSLTTOOLS-15344233
  • published25 Feb 2026
  • disclosed24 Feb 2026

Introduced: 24 Feb 2026

CVE-2025-10911  (opens in a new tab)
CWE-825  (opens in a new tab)

How to fix?

Upgrade SLES:15.5 libxslt-tools to version 1.1.34-150400.3.13.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libxslt-tools package and not the libxslt-tools package as distributed by SLES. See How to fix? for SLES:15.5 relevant fixed versions and status.

A use-after-free vulnerability was found in libxslt while parsing xsl nodes that may lead to the dereference of expired pointers and application crash.

CVSS Base Scores

version 3.1