Cross-site Request Forgery (CSRF) Affecting luajit package, versions <2.1.0~beta3+git.1624618403.e9577376-150400.4.2.1


Severity

Recommended
medium

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.84% (57th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES155-LUAJIT-5752453
  • published4 Jul 2023
  • disclosed6 Dec 2023

Introduced: 4 Jul 2023

CVE-2017-7557  (opens in a new tab)
CWE-352  (opens in a new tab)

How to fix?

Upgrade SLES:15.5 luajit to version 2.1.0~beta3+git.1624618403.e9577376-150400.4.2.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream luajit package and not the luajit package as distributed by SLES. See How to fix? for SLES:15.5 relevant fixed versions and status.

dnsdist version 1.1.0 is vulnerable to a flaw in authentication mechanism for REST API potentially allowing CSRF attack.