Insufficient Compartmentalization Affecting nvidia-container-toolkit package, versions <1.18.0-150200.5.17.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
1.11% (63rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES155-NVIDIACONTAINERTOOLKIT-14105423
  • published25 Nov 2025
  • disclosed24 Nov 2025

Introduced: 24 Nov 2025

CVE-2024-0135  (opens in a new tab)
CWE-653  (opens in a new tab)

How to fix?

Upgrade SLES:15.5 nvidia-container-toolkit to version 1.18.0-150200.5.17.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream nvidia-container-toolkit package and not the nvidia-container-toolkit package as distributed by SLES. See How to fix? for SLES:15.5 relevant fixed versions and status.

NVIDIA Container Toolkit contains an improper isolation vulnerability where a specially crafted container image could lead to modification of a host binary. A successful exploit of this vulnerability may lead to code execution, denial of service, escalation of privileges, information disclosure, and data tampering.

CVSS Base Scores

version 3.1