Out-of-bounds Write Affecting nvidia-open-driver-G06-signed-default-devel package, versions <550.90.07-150500.3.47.1


Severity

Recommended
high

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.28% (19th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES155-NVIDIAOPENDRIVERG06SIGNEDDEFAULTDEVEL-7246840
  • published12 Jun 2024
  • disclosed11 Jun 2024

Introduced: 11 Jun 2024

CVE-2024-0090  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade SLES:15.5 nvidia-open-driver-G06-signed-default-devel to version 550.90.07-150500.3.47.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream nvidia-open-driver-G06-signed-default-devel package and not the nvidia-open-driver-G06-signed-default-devel package as distributed by SLES. See How to fix? for SLES:15.5 relevant fixed versions and status.

NVIDIA GPU driver for Windows and Linux contains a vulnerability where a user can cause an out-of-bounds write. A successful exploit of this vulnerability might lead to code execution, denial of service, escalation of privileges, information disclosure, and data tampering.

CVSS Base Scores

version 3.1