Out-of-bounds Read Affecting opensc package, versions <0.22.0-150400.3.17.1


Severity

Recommended
0.0
low
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.26% (19th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES155-OPENSC-17614205
  • published27 Jun 2026
  • disclosed26 Jun 2026

Introduced: 26 Jun 2026

CVE-2025-66037  (opens in a new tab)
CWE-125  (opens in a new tab)

How to fix?

Upgrade SLES:15.5 opensc to version 0.22.0-150400.3.17.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream opensc package and not the opensc package as distributed by SLES. See How to fix? for SLES:15.5 relevant fixed versions and status.

OpenSC is an open source smart card tools and middleware. Prior to version 0.27.0, feeding a crafted input to the fuzz_pkcs15_reader harness causes OpenSC to perform an out-of-bounds heap read in the X.509/SPKI handling path. Specifically, sc_pkcs15_pubkey_from_spki_fields() allocates a zero-length buffer and then reads one byte past the end of that allocation. This issue has been patched in version 0.27.0.

CVSS Base Scores

version 3.1