Out-of-bounds Read Affecting opensc package, versions <0.22.0-150400.3.3.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.29% (22nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES155-OPENSC-5711001
  • published16 Jun 2023
  • disclosed15 Jun 2023

Introduced: 15 Jun 2023

CVE-2023-2977  (opens in a new tab)
CWE-125  (opens in a new tab)

How to fix?

Upgrade SLES:15.5 opensc to version 0.22.0-150400.3.3.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream opensc package and not the opensc package as distributed by SLES. See How to fix? for SLES:15.5 relevant fixed versions and status.

A vulnerbility was found in OpenSC. This security flaw cause a buffer overrun vulnerability in pkcs15 cardos_have_verifyrc_package. The attacker can supply a smart card package with malformed ASN1 context. The cardos_have_verifyrc_package function scans the ASN1 buffer for 2 tags, where remaining length is wrongly caculated due to moved starting pointer. This leads to possible heap-based buffer oob read. In cases where ASAN is enabled while compiling this causes a crash. Further info leak or more damage is possible.

CVSS Base Scores

version 3.1