Information Exposure Affecting opensc package, versions <0.22.0-150400.3.9.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
1.16% (63rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES155-OPENSC-6672955
  • published24 Apr 2024
  • disclosed23 Apr 2024

Introduced: 23 Apr 2024

CVE-2023-5992  (opens in a new tab)
CWE-203  (opens in a new tab)

How to fix?

Upgrade SLES:15.5 opensc to version 0.22.0-150400.3.9.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream opensc package and not the opensc package as distributed by SLES. See How to fix? for SLES:15.5 relevant fixed versions and status.

A vulnerability was found in OpenSC where PKCS#1 encryption padding removal is not implemented as side-channel resistant. This issue may result in the potential leak of private data.

CVSS Base Scores

version 3.1