Out-of-bounds Write Affecting opensc package, versions <0.22.0-150400.3.12.1


Severity

Recommended
0.0
low
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.35% (27th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES155-OPENSC-8097269
  • published26 Sept 2024
  • disclosed25 Sept 2024

Introduced: 25 Sep 2024

CVE-2024-8443  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade SLES:15.5 opensc to version 0.22.0-150400.3.12.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream opensc package and not the opensc package as distributed by SLES. See How to fix? for SLES:15.5 relevant fixed versions and status.

A heap-based buffer overflow vulnerability was found in the libopensc OpenPGP driver. A crafted USB device or smart card with malicious responses to the APDUs during the card enrollment process using the pkcs15-init tool may lead to out-of-bound rights, possibly resulting in arbitrary code execution.

CVSS Base Scores

version 3.1