Arbitrary Argument Injection Affecting python311-GitPython package, versions <3.1.34.1693646983.2a2ae77-150400.9.8.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.55% (44th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES155-PYTHON311GITPYTHON-19779572
  • published14 Sept 2026
  • disclosed8 Sept 2026

Introduced: 8 Sep 2026

CVE-2026-73624  (opens in a new tab)
CWE-88  (opens in a new tab)

How to fix?

Upgrade SLES:15.5 python311-GitPython to version 3.1.34.1693646983.2a2ae77-150400.9.8.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream python311-GitPython package and not the python311-GitPython package as distributed by SLES. See How to fix? for SLES:15.5 relevant fixed versions and status.

GitPython versions before 3.1.54 contain an arbitrary file overwrite vulnerability in the Diffable.diff method that fails to validate git options passed through kwargs. Attackers can supply the --output argument via the other parameter or output kwarg to write patch content to attacker-chosen file paths at process privilege level.

CVSS Base Scores

version 3.1