CVE-2024-11584 Affecting python311-jsonpointer package, versions <2.3-150400.11.5.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.14% (4th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES155-PYTHON311JSONPOINTER-16755502
  • published19 May 2026
  • disclosed18 May 2026

Introduced: 18 May 2026

CVE-2024-11584  (opens in a new tab)

How to fix?

Upgrade SLES:15.5 python311-jsonpointer to version 2.3-150400.11.5.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream python311-jsonpointer package and not the python311-jsonpointer package as distributed by SLES. See How to fix? for SLES:15.5 relevant fixed versions and status.

cloud-init through 25.1.2 includes the systemd socket unit cloud-init-hotplugd.socket with default SocketMode that grants 0666 permissions, making it world-writable. This is used for the "/run/cloud-init/hook-hotplug-cmd" FIFO. An unprivileged user could trigger hotplug-hook commands.

CVSS Base Scores

version 3.1