Use After Free Affecting python311-msgpack package, versions <1.0.7-150400.10.9.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.49% (40th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES155-PYTHON311MSGPACK-19680393
  • published11 Sept 2026
  • disclosed3 Sept 2026

Introduced: 3 Sep 2026

CVE-2026-57585  (opens in a new tab)
CWE-416  (opens in a new tab)

How to fix?

Upgrade SLES:15.5 python311-msgpack to version 1.0.7-150400.10.9.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream python311-msgpack package and not the python311-msgpack package as distributed by SLES. See How to fix? for SLES:15.5 relevant fixed versions and status.

MessagePack is the serializer implementation for Python msgpack.org. Prior to 1.2.1, there is an Out-of-bounds read/crash on Unpacker reuse after a caught error, potentially leading to a DoS attack. If the Unpacker is used repeatedly after an error occurs, the process may crash with a SEGV. This issue has been fixed in version 1.2.1.

CVSS Base Scores

version 3.1