XML Injection Affecting python311-xmltodict package, versions <0.13.0-150400.12.7.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.45% (37th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES155-PYTHON311XMLTODICT-13450775
  • published8 Oct 2025
  • disclosed7 Oct 2025

Introduced: 7 Oct 2025

CVE-2025-9375  (opens in a new tab)
CWE-91  (opens in a new tab)

How to fix?

Upgrade SLES:15.5 python311-xmltodict to version 0.13.0-150400.12.7.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream python311-xmltodict package and not the python311-xmltodict package as distributed by SLES. See How to fix? for SLES:15.5 relevant fixed versions and status.

XML Injection vulnerability in xmltodict allows Input Data Manipulation. This issue affects xmltodict: from 0.14.2 before 0.15.1.

NOTE: the scope of this CVE is disputed by the vendor on the grounds that xmltodict.unparse() delegates element-name handling to Python's xml.sax.saxutils.XMLGenerator, and that XMLGenerator should be the component performing validation.

CVSS Base Scores

version 3.1