CVE-2022-3171 Affecting python3-constantly package, versions <15.1.0-150000.3.4.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
1.28% (70th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES155-PYTHON3CONSTANTLY-5757382
  • published6 Jul 2023
  • disclosed4 Jul 2023

Introduced: 4 Jul 2023

CVE-2022-3171  (opens in a new tab)

How to fix?

Upgrade SLES:15.5 python3-constantly to version 15.1.0-150000.3.4.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream python3-constantly package and not the python3-constantly package as distributed by SLES. See How to fix? for SLES:15.5 relevant fixed versions and status.

A parsing issue with binary data in protobuf-java core and lite versions prior to 3.21.7, 3.20.3, 3.19.6 and 3.16.3 can lead to a denial of service attack. Inputs containing multiple instances of non-repeated embedded messages with repeated or unknown fields causes objects to be converted back-n-forth between mutable and immutable forms, resulting in potentially long garbage collection pauses. We recommend updating to the versions mentioned above.

CVSS Base Scores

version 3.1