Improper Validation of Array Index Affecting rsync package, versions <3.2.3-150400.3.34.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.31% (22nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES155-RSYNC-18914997
  • published18 Aug 2026
  • disclosed17 Aug 2026

Introduced: 17 Aug 2026

CVE-2026-53792  (opens in a new tab)
CWE-129  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade SLES:15.5 rsync to version 3.2.3-150400.3.34.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream rsync package and not the rsync package as distributed by SLES. See How to fix? for SLES:15.5 relevant fixed versions and status.

rsync before 3.5.0 contains an out-of-bounds read vulnerability in the sender-side block matching logic that allows a malicious receiver to trigger memory access before the start of an allocated buffer by sending a crafted checksum block with a length of zero. Attackers can send a specially crafted checksum set containing a zero-length block to cause a negative offset calculation during delta computation, resulting in an out-of-bounds read of file data buffer memory on the sender side.

CVSS Base Scores

version 3.1