Link Following Affecting rsync package, versions <3.2.3-150400.3.34.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.12% (2nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES155-RSYNC-18915027
  • published18 Aug 2026
  • disclosed17 Aug 2026

Introduced: 17 Aug 2026

CVE-2026-53799  (opens in a new tab)
CWE-59  (opens in a new tab)
CWE-367  (opens in a new tab)

How to fix?

Upgrade SLES:15.5 rsync to version 3.2.3-150400.3.34.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream rsync package and not the rsync package as distributed by SLES. See How to fix? for SLES:15.5 relevant fixed versions and status.

rsync before 3.5.0 contains a symlink race condition vulnerability that allows local attackers to cause rsync to apply arbitrary ACLs or extended attributes to unintended files by substituting a symlink at a predictable destination path between the file write and the subsequent acl_set_file() or lsetxattr() call. Attackers can exploit this timing window to redirect ACL and xattr application through a crafted symlink to files outside the intended destination tree, potentially granting elevated permissions and enabling local privilege escalation.

CVSS Base Scores

version 3.1