Improper Certificate Validation Affecting rsync package, versions <3.2.3-150400.3.34.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.19% (8th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES155-RSYNC-18915040
  • published18 Aug 2026
  • disclosed17 Aug 2026

Introduced: 17 Aug 2026

CVE-2026-70454  (opens in a new tab)
CWE-295  (opens in a new tab)

How to fix?

Upgrade SLES:15.5 rsync to version 3.2.3-150400.3.34.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream rsync package and not the rsync package as distributed by SLES. See How to fix? for SLES:15.5 relevant fixed versions and status.

rsync 3.2.0 through 3.2.3 (openssl mode) and rsync-ssl through 3.4.4 (stunnel mode) contain a TLS certificate validation vulnerability that allows on-path attackers to intercept encrypted sessions by presenting self-signed or otherwise invalid certificates. Attackers can exploit the failure to validate server TLS certificates against a trusted CA or verify certificate hostname matching to decrypt or tamper with rsync session content without detection by the client.

CVSS Base Scores

version 3.1