Race Condition Affecting sccache package, versions <0.4.2~3-150400.3.3.1


Severity

Recommended
0.0
low
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
1.24% (69th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES155-SCCACHE-5882617
  • published6 Sept 2023
  • disclosed5 Sept 2023

Introduced: 5 Sep 2023

CVE-2021-45710  (opens in a new tab)
CWE-362  (opens in a new tab)

How to fix?

Upgrade SLES:15.5 sccache to version 0.4.2~3-150400.3.3.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream sccache package and not the sccache package as distributed by SLES. See How to fix? for SLES:15.5 relevant fixed versions and status.

An issue was discovered in the tokio crate before 1.8.4, and 1.9.x through 1.13.x before 1.13.1, for Rust. In certain circumstances involving a closed oneshot channel, there is a data race and memory corruption.

CVSS Base Scores

version 3.1