CVE-2024-39134 Affecting zziplib-devel package, versions <0.13.69-150000.3.20.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.6% (45th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES155-ZZIPLIBDEVEL-7856993
  • published3 Sept 2024
  • disclosed2 Sept 2024

Introduced: 2 Sep 2024

CVE-2024-39134  (opens in a new tab)

How to fix?

Upgrade SLES:15.5 zziplib-devel to version 0.13.69-150000.3.20.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream zziplib-devel package and not the zziplib-devel package as distributed by SLES. See How to fix? for SLES:15.5 relevant fixed versions and status.

A Stack Buffer Overflow vulnerability in zziplibv 0.13.77 allows attackers to cause a denial of service via the __zzip_fetch_disk_trailer() function at /zzip/zip.c.

CVSS Base Scores

version 3.1